New Google Chorme Plug-in is made for Google Wave

When I first heard about the new Google Chrome plugin for Internet Explorer this morning, I wasn’t sure what to make of it.  I’m a huge Chrome fan, but didn’t see why it was such a huge deal that you could run Chrome through IE.  Now I get it.

One week from tomorrow, Google Wave will be opening up to 100,000 users.  According to the Chrome team, Internet Explorer simply can’t handle technologies associated with HTML5 or handle JavaScript efficiently enough.  Before IE users will be allowed to use Wave, they’ll be forced to install the plug-in (or use an alternate browser).

wave-chrome-ieWhile most of us can (and do) use browsers other than Internet Explorer, many people in corporate environments don’t have the ability to do that.  This plug-in takes care of that for them, and should give them a great way to use Google Wave.  If you’d like to see developer’s information about the Chrome Frame, you can get it here.